Menu item keyboard shortcut editor fix? Seems like broken to me

Vith's Avatar

Vith

07 Dec, 2012 12:31 PM

Recently updated to 6.1.2 and all my custom keyboard shortcuts stopped to work. When I try to set them up - I just cant. What I tried is: selecting an item, pressing some keys - nothing. Just silence or dings all the time.

Not sure about keyboard editor (as I set it up a long time ago) but these shortcuts were still working in previous version. And now suddenly nothing...

  1. 1 Posted by Vith on 12 Dec, 2012 01:03 PM

    Vith's Avatar

    5 days and completely no response? That's reassuring.

  2. 2 Posted by Damazio on 12 Dec, 2012 05:59 PM

    Damazio's Avatar

    Vith, try to reboot or trash the preferences file below. Alternatively, check if you're running other apps that might be intercepting hotkeys like Typinator, QuickKeys X, etc.

    /Users/<username>/Library/Preferences/com.cocoatech.pathfinder.plist

  3. 3 Posted by Vith on 12 Dec, 2012 08:55 PM

    Vith's Avatar

    Thanks for response. I closed every other app - same results. Cannot set up any key shortcut. Rebooted, restarted PathFinder etc. Nothing.

    Deleted preferences - lost all my settings in the process (duh...) but still no success. Well, I can set up F4, or cmd+F2. But cannot use F2 and some other shortcuts - that were previously possible.

    I went back to 6.0.6 (the only previous version I found on my hdd as there doesn't seem to be any kind of download repo with different versions) and guess what - F2 can be bound and it works perfectly. So I'm gonna go ahead and say that newest version introduced a bug...

  4. 4 Posted by Damazio on 12 Dec, 2012 11:29 PM

    Damazio's Avatar

    OK, Vith, I know what it is, you gave me the info I needed.
    Version 6.1.2 introduced some new commands and assigned some default F keys to them. Check the menu Commands > Dual Browser. F2 must be assigned to one of them. All you need to do is to clear the F2 key for that command in the hotkey preferences.

    When you hear the system error beep when trying to set a hotkey in the preferences, it's because it's already taken by another command. When you no sound is heard, it means that combination is not accepted.

    I agree that new menu commands shouldn't come with a default shortcut and potentially overwrite a custom user assignment. I'll mention this to the dev.

    Cheers.

  5. 5 Posted by Vith on 12 Dec, 2012 11:47 PM

    Vith's Avatar

    Finally got it. It was actually View > Dual Browser -> Switch Panes (not Commands).

    Thanks for your help.

  6. 6 Posted by Damazio on 13 Dec, 2012 12:03 AM

    Damazio's Avatar

    Thanks for the correction, Vith. I cleared all F keys when I updated to 6.1.2. Cheers.

  7. Dragan closed this discussion on 19 Dec, 2012 11:41 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac