Searching an attached NAS folder

Mark's Avatar

Mark

22 Aug, 2012 08:33 AM

Hello,

I was trying to search a folder that is exposed from my Synology DS209 NAS box. When I try various search criteria it seems as if Path Finder is not performing a search. I never heard the hard drive within the NAS spin up or anything that would indicate there is activity. I am able to perform a search on my local hard drive (though that didn't work the first few attempts I tried), but not against the NAS box. What is going on? Is Path Finder able to search the network drives?

Regards,
Mark

  1. 1 Posted by Damazio on 22 Aug, 2012 04:48 PM

    Damazio's Avatar

    Mark, have you tried using both Spotlight and Search mode?

  2. 2 Posted by Mark on 22 Aug, 2012 11:19 PM

    Mark's Avatar

    Hello Damazio,

    yes, I tried pressing both of those buttons as I didn't really know what they did or what the difference was. I was sort of stumbling around to figure it out why I wasn't finding anything, even though I know it was there.

    Regards,
    Mark

  3. 3 Posted by Damazio on 23 Aug, 2012 12:03 AM

    Damazio's Avatar

    There's an open ticket on searching network drives using Spotlight but Search mode should work fine. I attached that ticket to this post and notified Dragan (dev). In his own words:

    Spotlight indexing doesn't work by default on network volumes. There is a way to turn it on (http://hints.macworld.com/article.php?story=20050430233117572), but his has to be done every time a volume is mounted.

    The other thing is that this doesn't seem to work reliably. I tried it on couple of mounted shares (both AFP and SMB) and even though the status of them were reported as "Indexing enabled", no indexing was done and Spotlight can't find any file on them.

    Simple old-fashion file search seems to work fine on network volumes.

  4. 4 Posted by Damazio on 23 Aug, 2012 02:04 AM

    Damazio's Avatar

    Actually I just tried searching a network volume (AFP) and Search mode also didn't deliver any results. We'll notify you when there's a status change on the ticket, Mark.

  5. Damazio closed this discussion on 23 Aug, 2012 02:04 AM.

  6. Damazio re-opened this discussion on 23 Aug, 2012 02:04 AM

  7. 5 Posted by Mark on 23 Aug, 2012 08:49 AM

    Mark's Avatar

    Thanks, Damazio. I will look forward to a resolution in the future.

  8. Damazio closed this discussion on 23 Aug, 2012 01:42 PM.

  9. Support Staff 6 Posted by Dragan on 29 Apr, 2013 09:02 PM

    Dragan's Avatar

    In order to use Spotlight search on network volumes, one has to force Spotlight indexing for a newly mounted network volume.

    Please read this knowledge base entry. It explains in details everything related to this particular issue.

  10. Dragan closed this discussion on 29 Apr, 2013 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac