Can someone tell me how to get rid of APPS extensions?

albertkinng's Avatar

albertkinng

09 Jun, 2012 04:03 AM

I don't like to see my apps with a .app extensions on it... how do I get rid of them?

  1. 1 Posted by Damazio on 10 Jun, 2012 05:36 PM

    Damazio's Avatar

    Hit Command-J and disable Always show file extensions.

  2. Damazio closed this discussion on 10 Jun, 2012 05:36 PM.

  3. albertkinng re-opened this discussion on 10 Jun, 2012 06:17 PM

  4. 2 Posted by albertkinng on 10 Jun, 2012 06:17 PM

    albertkinng's Avatar

    If I do that I wont be able to see the other files extensions. I want to
    see others files extentions but I dont want my apps with the extentions!
    Get it? ITunes not iTunes.app and sound.mp3 not sound.
    >

  5. 3 Posted by Damazio on 10 Jun, 2012 08:58 PM

    Damazio's Avatar

    You can switch to This window only in the View Options of the Applications folder or disable Always show file extensions altogether, select all your apps, press Option-Command-I and check Hide extension in the Attributes section.

  6. Damazio closed this discussion on 10 Jun, 2012 08:58 PM.

  7. albertkinng re-opened this discussion on 10 Jun, 2012 10:49 PM

  8. 4 Posted by albertkinng on 10 Jun, 2012 10:52 PM

    albertkinng's Avatar

    it is OFFICIALLY A MAYOR BUG!!! here is the prove: I can't do anything switching from show or don't show the extention!! work this out please and don't close the topic if it's not resolved YET!!! thx

  9. 5 Posted by albertkinng on 10 Jun, 2012 10:55 PM

    albertkinng's Avatar

    and this one is the best! Exactly your instructions! STEP BY STEP

  10. 6 Posted by Damazio on 11 Jun, 2012 10:53 PM

    Damazio's Avatar

    OK, let's try to work together on this...

    First you can't show/hide extensions on a file type basis. You can disable Always show file extensions for This window only on the Applications folder, for example. Since you can have apps elsewhere, your best bet is to disable Always show file extensions for All windows. That being said and concerning your screenshot 1, the screencast below shows that I'm not suffering from your official major bug so it's hard to come to a conclusion to what is going on. I tried List View, Icon View and the changes are visible in the browser, in real time. Try to refresh the browser or relaunch Path Finder.

    Concerning your screenshot 2 and, after some research, here are some facts showing that extensions in OS X are a bit of a gray area and apps have a bit of a special treatment:


    Finally, a closed thread doesn't mean anything because it's never permanent. Some users reply back, some don't, even when questioned to provide more info. A resolved thread is simply a thread that was answered with a constructive output from the staff so it's easier to manager our queues of hundreds of posts. Simply, if it's closed and there's no reply, it's a thread less to keep on watch and close later. Reopening it, is as simple as replying back, you don't even have a reopen button. After a user replies more than 2 times, usually, I leave it open since I'm expecting a "success" post. If it's a "still no go" post, I'll leave it open as well.

  11. 7 Posted by albertkinng on 11 Jun, 2012 11:27 PM

    albertkinng's Avatar

    Instead of 1,000 excuses with facts and data. Is way better to work around
    a problem and resolved it.

    I ask a friend about it (he didn't knew about Pathfinder btw... he bought
    one copy right away!) And he was able to help.

    1) he ask me if I replace the Finder completly. I said yes.
    2) he ask me to enable Finder again.I did it
    3) he told me to set a default on Finder about the overall icon view on
    preferences. I did that.
    4) he told me to launch Pathfinder again and set the icon views as the
    "Nice" person told me...(YOU). I did it.

    Everything works perfect now. Sad that you just want to throw in the face
    your knowledge without helping us. I wasn't asking how much you know about
    settings I was looking for help.

    But well... at the end Pathfinder 6 is great so keep coding and developing
    it seems your good at that.
    >

  12. 8 Posted by Damazio on 11 Jun, 2012 11:56 PM

    Damazio's Avatar

    My knowledge belongs to Google, and It's sad you picture me as arrogant when I actually tried to help. I'm no coder or developer. I'm a user, just like you, who took the time to, at least, try to figure something out. I'll try my best to spare you from any reply from me, in your future posts.
    Glad you worked it out.

  13. Damazio closed this discussion on 11 Jun, 2012 11:56 PM.

  14. albertkinng re-opened this discussion on 12 Jun, 2012 12:41 AM

  15. 9 Posted by albertkinng on 12 Jun, 2012 12:41 AM

    albertkinng's Avatar

    LOL thought you were a Cocoatech developer. Sorry. Is that sometimes
    support people get tired of dumb questions and treat everyone as trash. If
    you are a user like me then I understand the fast and do this attitude I'm
    like that sometimes but for a developer is kind of un-professional. So thx
    for the help and hope my problem get solved by others when get to my
    question browsing in this forum.

  16. Damazio closed this discussion on 12 Jun, 2012 01:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac