PathFinder 6 Not Acting As Default Finder

Marty Plumbo's Avatar

Marty Plumbo

08 Jun, 2012 01:28 AM

When I double-click on a folder to open it, the MacOS Finder opens, rather than PathFinder.

With PathFinder 5 this worked as expected, but not amount of tweaking of the PathFinder 6 preferences seems to have any effect.

Help! ;-)

  1. 1 Posted by Damazio on 30 Jun, 2012 02:57 PM

    Damazio's Avatar

    Where are you double-clicking from? Path Finder's browser, Finder's or Path Finder's desktop?

  2. Damazio closed this discussion on 30 Jun, 2012 02:57 PM.

  3. Marty Plumbo re-opened this discussion on 30 Jun, 2012 10:26 PM

  4. 2 Posted by Marty Plumbo on 30 Jun, 2012 10:26 PM

    Marty Plumbo's Avatar

    Double-clicking on a hard drive icon on the desktop, for instance, open the Finder browser window, not PathFinder's.

    ----------

  5. 3 Posted by Damazio on 30 Jun, 2012 11:26 PM

    Damazio's Avatar

    Have you tried to enable Preferences > Finder > Hide Finder's desktop and Preferences > Features > Desktop > Show Path Finder desktop?

  6. 4 Posted by Marty Plumbo on 30 Jun, 2012 11:50 PM

    Marty Plumbo's Avatar

    I'm not sure I want to use PathFinder's desktop - I'd prefer to stick with the OS's native one.

    So, to have PathFinder act as a consistent replacement for the system Finder I have to use your alternate desktop?

    -----------

  7. 5 Posted by Marty Plumbo on 30 Jun, 2012 11:52 PM

    Marty Plumbo's Avatar

    Well, I tried it with the PathFinder desktop enabled but still get the same behavior.

    Clicking on the desktop drive icons still brings up the system Finder windows.

    --------

  8. 6 Posted by Damazio on 30 Jun, 2012 11:56 PM

    Damazio's Avatar

    Try to disable and enable again Preferences > General > Set as the default file browser. Then, hold the Option key, right click on Finder's icon on the dock, choose Relaunch and try again.

  9. 7 Posted by Marty Plumbo on 01 Jul, 2012 12:04 AM

    Marty Plumbo's Avatar

    Same behavior. Sorry. Thanks for hanging in there with me though! ;-)

    -----------

  10. 8 Posted by Damazio on 01 Jul, 2012 02:17 PM

    Damazio's Avatar

    No problem, Marty.
    At least, using Path Finder's desktop, it should work (FInder's desktop is tied to Finder).
    If you wanna go further, I advise you to trash your preferences file and start Path Finder from scratch. If it doesn't work, just put the preferences file back:

    /Users/<username>/Library/Preferences/com.cocoatech.pathfinder.plist

  11. 9 Posted by Marty Plumbo on 01 Jul, 2012 02:52 PM

    Marty Plumbo's Avatar

    Nope. That didn't fix it either.

    -------

  12. 10 Posted by Damazio on 14 Jul, 2012 02:49 AM

    Damazio's Avatar

    Have you updated to v6.0.3? Does it still happen?
    Also try the following troubleshooting measures:

    • Trashing the Finder and Dock plist files
    • Emptying both the system and user cache folders (by hand or with some third-party app like Yasu, Onyx, etc.)
    • Repairing permissions
    • Trying it on a new user account
    • Installing the latest OS X combo update
  13. 11 Posted by Marty Plumbo on 14 Jul, 2012 06:37 AM

    Marty Plumbo's Avatar

    I just upgraded a few minutes ago and, unfortunately, it still does it.

    If I open a hard drive icon on my desktop, the MacOS system finder opens. Not PathFinder. :-(

    --------------

  14. 12 Posted by Damazio on 19 Jul, 2012 01:25 AM

    Damazio's Avatar

    Well, Marty, please reopen if you tried all my troubleshooting tips and still get the same behavior.

  15. Damazio closed this discussion on 19 Jul, 2012 01:25 AM.

  16. Marty Plumbo re-opened this discussion on 19 Jul, 2012 06:47 AM

  17. 13 Posted by Marty Plumbo on 19 Jul, 2012 06:47 AM

    Marty Plumbo's Avatar

    I'm not sure how to re-open it -there doesn't appear to be a button to do that.

    Just curious, why did you close this in the first place?

    ----------

  18. 14 Posted by Damazio on 19 Jul, 2012 11:07 AM

    Damazio's Avatar

    You just re-opened it, it's automatically done just by replying.

    I closed it because if a user doesn't reply back, it's a thread less for me to manage.
    Besides, you didn't tell me if you tried the troubleshooting tips so I thought you would take some time to test it and reply when/if you find something new.

    Don't worry, a closed thread is a thread which had a constructive reply from the staff, nothing else. It's not permanent.

  19. Damazio closed this discussion on 24 Jul, 2012 04:01 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac