Path Finder Desktop + Mission Control in 10.7.3

chrispyslice's Avatar

chrispyslice

07 Apr, 2012 02:17 PM

Mission Control renders incorrectly when PFs desktop is shown on 10.7.3.

I right clicked on the Desktop -> "Show View Options" -> "Set Colors..." -> "[X] Use the Finder's desktop window level" which fixed the problem of icons not appearing when desktop Exposé is used, but when I go into Mission Control graphical "glitching" occurs like in the screenshot.

  1. 1 Posted by Damazio on 07 Apr, 2012 08:43 PM

    Damazio's Avatar

    What is the exact graphic glitch you're experiencing? I can't tell from your screenshot.
    Have you tried to change the Desktop window level adjustment?

  2. 2 Posted by chrispyslice on 09 Apr, 2012 02:24 AM

    chrispyslice's Avatar

    Sorry, I wasn't clear enough. I didn't mean a graphical glitch in terms of graphics cards and stuff like that, but basically the desktop icons appearing "over" Mission Control is what I meant to communicate. If I quit PF and show the Finder's desktop then go into Mission Control, those icons do not appear within Mission Control.

    I have tried changing the desktop window level. My current value is 0. If the value is 0, I can invoke Desktop Exposé, the icons appear on the desktop. If the value is >= 1, if I invoke Desktop Exposé, the icons disappear as well as any windows.

  3. 3 Posted by Damazio on 09 Apr, 2012 04:52 PM

    Damazio's Avatar

    Let me see if I get this straight, if you use Finder's desktop and invoke Mission Control, Finder's desktop icons do not show up, right? I think that's the normal behavior.
    If you use Path Finder's desktop and uncheck Use the Finder's desktop window level it mimics the normal Finder behavior, right?
    So, Path Finder has an extra feature of showing the desktop icons when Mission Control is invoked, but since Mission Control has its own layer covering the screen (the gray background is part of the whole layer), for this feature to work, Path Finder has to draw its own desktop layer on top of Mission Control, otherwise you wouldn't see the icons. I think it's normal, no?

    You can put labels below icons (so the width gets reduced and fits on the gray background area) and move them down so they don't overlap the last space shown in your screenshot.

  4. Damazio closed this discussion on 12 Apr, 2012 11:05 AM.

  5. chrispyslice re-opened this discussion on 12 Apr, 2012 09:28 PM

  6. 4 Posted by chrispyslice on 12 Apr, 2012 09:28 PM

    chrispyslice's Avatar

    Sure, but my point is that I can't make is so that the icons to appear on the desktop when Desktop Expose is invoked (not in Mission Control but, for example, "Desktop" as a hot corner) AND the icons not showing while Mission Control is invoked.

  7. 5 Posted by Damazio on 12 Apr, 2012 10:01 PM

    Damazio's Avatar

    Ok, I get it now, sorry about the confusion and thanks for keeping up with me. Finder must issue another call to hide desktop icons only in Mission Control. So, right now the only work-around is to:

    • enable both Finder and Path Finder desktops
    • disable 'Use the Finder's desktop window level'
    • enable 'Show desktop background'

    There will be some quick glitches when using Mission Control, showing Finder's icons for a split second and when invoking Desktop Expose, it will hide Path Finder's icons and show Finder's icons underneath.

    This thread will remain open and the devs are notified to see if it's a bug or a limitation on OS X APIs.

  8. 6 Posted by Michael on 21 Apr, 2012 07:23 AM

    Michael's Avatar

    I've added this to our bug tracker. I'm not certain if it can be resolved since we can have no control over Mission Control, but it's worth investigating.

  9. 7 Posted by User on 27 Apr, 2012 01:23 AM

    User's Avatar

    Same along with the PF trash can. I disabled Finder and can't use the trash can on my dock, so I enabled the PF desktop trash can. The problem is I want to invoke expose and delete the files in the trash can, but it slides off.

  10. Support Staff 8 Posted by Dragan on 18 Jun, 2012 06:53 PM

    Dragan's Avatar

    I came a bit late in this discussion, but since it's still an open issue, it's never too late.

    All this inconsistent behaviour was introduced with Lion and it's Mission Control. Everything worked okay regarding Exposé and "Show Desktop" hotkey (F11) in Snow Leopard. At the moment Path Finder behaves as such (assuming that Finder is not running):

    Case 1:
    Show Path Finder desktop is ON Use the Finder's desktop window level is OFF Invoking Mission Control, desktop icons slide out and disappear, PF Trash icon (is shown) does the same too. This is correct behaviour.
    Invoking "Show Desktop" hotkey (F11), desktop icons slide out and disappear, PF Trash icon (is shown) does the same too. This is incorrect behaviour**.

    Case 2:
    Show Path Finder desktop is ON Use the Finder's desktop window level is ON Invoking Mission Control, PF Trash icon (is shown) slides out and disappears, but desktop icons don't slide out, they stay on Lion grey-textured background. This is incorrect behaviour.
    Invoking "Show Desktop" hotkey (F11), desktop icons stay on desktop, PF Trash icon (is shown) slides out and disappears. This is correct behaviour (except for the Trash icon)**.

    This shows that one set of preferences shows correct behaviour in Mission Control but fails for "Show Desktop", while the other setting does completely the opposite. Apple changed the way Desktop level window behaves in Lion. We tried to customise that and use some setting flags, but it didn't help. Apple has been informed about this as it's filled as a bug, but so far we didn't receive any response on it.

    One of these days I'll try to investigate the issue again, but I'm not sure if there's anything I can do about it. Anyway, it'll stay open in the bug tracker.

  11. Dragan closed this discussion on 18 Jun, 2012 06:53 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac