BUG: Prompted to activate after each restart (build 2124)

bill's Avatar

bill

21 Mar, 2022 04:16 PM

After each restart of my M1 MB Pro, I'm prompted to activate Path Finder (or continue to use trial). When I select 'Activate', PF confirms successful activation. Upon subsequent restarts, I have the same experience repeated.

  1. 1 Posted by Sandro on 23 Mar, 2022 12:04 PM

    Sandro's Avatar

    +1

    Also, PF says "Trial Mode - Buy Now" in top left corner of main window

  2. 2 Posted by mrolfer on 24 Mar, 2022 12:35 PM

    mrolfer's Avatar

    Same issues here

  3. 3 Posted by Sandro on 25 Mar, 2022 02:07 AM

    Sandro's Avatar

    Would be great to get some indication this has been acknowledged and will be fixred before the trial expires.

  4. Support Staff 4 Posted by Dragan on 11 Apr, 2022 03:51 PM

    Dragan's Avatar

    Hello all,

    I sincerely apologise for for your troubles with subscription activation. There was a bug, which could lead to subscription deactivation after machine restart, or even to excessive license check in some situations. Even though I couldn't reproduce those issues, I believe I fixed them in the newest build, which I've just uploaded to the server.

    The new build version is 2128 and you can download it here, or you can update your current copy using in-app updater, available from the main menu **Path Finder > Check for Updates…" menu item. Please update to this version and see if it fixes your problems with license activation. If you still have the same problems, please let me know.

  5. 5 Posted by Paul on 19 Jul, 2022 12:51 AM

    Paul's Avatar

    I'm having the same issue as others: every time Path Finder is opened, it shows I'm using a trial, I 'activate' my existing license, it shows my 'status' as 'active', I ask it to 'check' my active status, I get a message saying "Check Successful!", and then Path Finder opens saying "Trial Mode - Buy Now". I have deleted Path Finder, downloaded a new version, but the process repeats. I've used the link posted here (build version 2128) and the same thing happens.

  6. 6 Posted by Niels J. Hansen on 28 Jul, 2022 07:57 AM

    Niels J. Hansen's Avatar

    Same issue after migrating to e new Macbook. Tried to:

    • Activate new installation. Activation OK. Still in Trial...
    • Deactivate, re-activate. Activation OK. Still in Trial...
    • Upgrading to latest build. Repeat Deactivation/Activation steps. Activation OK. Still in Trial...

    Something seems to be off with the activation code.

  7. 7 Posted by Mark Muldoon on 28 Jul, 2022 04:49 PM

    Mark Muldoon's Avatar

    I have the same experience as Neils Hanson and am running version 2136.

  8. 8 Posted by Josep Antoni Ig... on 29 Jul, 2022 07:23 AM

    Josep Antoni Ignacio Herrera's Avatar

    Hola amigos de Cocoatech,

    Tengo un problema con mi licencia de Pathfinder. Resulta que acabo de cambiar de macbook pro y en el nuevo no hay manera de activar mi licencia. Aunque cuando le digo "Activate" me dice que está activada la licencia para mi ordenador nuevo, resulta que después no hay manera de salir de la version Trial.
    ¿Cómo puedo resolver este problema?

    Un saludo bien cordial.

    Josep Antoni
    Barcelona

  9. 9 Posted by Niels J. Hansen on 02 Aug, 2022 01:26 PM

    Niels J. Hansen's Avatar

    I have 5 days left of Trial, and still no reply from Support? Should I worry?

  10. 10 Posted by dan on 02 Aug, 2022 02:21 PM

    dan's Avatar

    I have this same issue. I am running PF 2136. My PF Window says "Trial Mode - Buy Now!" When I click that link, it tells me I have 25 days left on my trial, and has a button to Activate. When I click the Activate button, it tells me my account is activated on this MacBook. If I click the Check button to check this activation it tells me "Check is Successful, this machine is Activated." However, PF continues to display the trial mode banner and continues to count down the trial mode day clock. I have restarted PF, and restarted the entire MacBook with no difference. I am running MacOS Monterey 12.5 on a 2019 MacBook Pro (NOT M1).

  11. 11 Posted by Josep A. Ignaci... on 03 Aug, 2022 01:01 PM

    Josep A. Ignacio's Avatar

    I have this same issue than Dan. Please, is there someone at Cocoatech who can give us support?

  12. Support Staff 12 Posted by Dragan on 05 Aug, 2022 09:51 PM

    Dragan's Avatar

    Hello everyone,

    First of all, my apologies for such delayed response. You revived an already closed thread. In the meanwhile, we started the process of transferring our support from Tender to Zendesk and unfortunately, this reopened thread somehow skipped my attention. Once again, I apologise for that.

    A few users have reported the similar issue and it seems that somehow something went out of sync with the local Path Finder credentials, kept in your login keychain. I still haven't figured out why that could happen, maybe a keychain item got corrupted or something. Once I figure it out, I'll make sure it cannot happen again. So far, I couldn't reproduce the issue. In the meanwhile, here's how you can solve the issue yourself:

    1. Open the Registration window and from the menu in the top-right, choose Sign Out, like in the attached picture signout.png.

    2. Once signed out, quit Path Finder.

    3. Open Keychain Access application and search in your login keychain for an item, with name starting with pfx, like in the attached picture keychain.png.

    4. Delete this item from your login keychain.

    5. Launch Path Finder, it will start in renewed 30-days trial mode. In the registration window chose Sign In.

    6. Sign in with your email address you used when you purchased Path Finder and your password, which you choose when signing in for the first time to activate your subscription. If you forgot your password, click on Forgot password? and you'll get an email how to reset it.

    After you signed in, you should see the details of your subscription, including its active status. Close the registration window and you should (finally) get out of the trial period.

    Please let me know if the above procedure didn't work for you!

    I apologise for the inconvenience regarding this. Once I figure out why this can happens sometimes, I'll fix it. And again, sincere apologies for the delay in responding. Once we're full transferred to Zendesk, such situations will not happen.

    Thanks a lot for your support, time and patience.

    -- Dragan

  13. 13 Posted by Niels J. Hansen on 08 Aug, 2022 01:48 PM

    Niels J. Hansen's Avatar

    I have experienced some difficulty with my keychain after upgrading to MacOS Ventura (beta), and this may be why I could not follow Dragans problem resolution 100%. However after "fiddling" a bid, it now seems to have resolved my issue.

    Thank you Dragon ;-)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac