BUG : A file still cannot be deleted after authentication

ryoichi's Avatar

ryoichi

16 Mar, 2022 08:17 PM

This problem was reported a while back, but it's still not fixed in PF2124. When I try to delete a file, a dialog box comes up saying that the item is not deletable. I take the option to authenticate, but PF still would not delete the file. This bug did not exist in PF 10.

PLEASE FIX IT!

  1. 1 Posted by Jay on 19 Mar, 2022 12:05 AM

    Jay's Avatar

    happening here as well. Annoying.

  2. Support Staff 2 Posted by Path Finder Sup... on 21 Mar, 2022 09:23 AM

    Path Finder Support Team's Avatar

    Hi everyone,

    Mary from Path Finder support here!

    Please navigate to your System Preferences > Security & Privacy > Privacy > Full Disk Access > delete your Path Finder from the list and then, re-add back and check it. Restart your app and check if the following behavior persists when deleting the file.

    If it does, please share with me an error you get when deleting. Additionally, specify the macOS and PF version you use.

    Best Regards,
    Mary 
    Path Finder Support Team

  3. Path Finder Support Team closed this discussion on 21 Mar, 2022 09:23 AM.

  4. ryoichi re-opened this discussion on 21 Mar, 2022 05:52 PM

  5. 3 Posted by ryoichi on 21 Mar, 2022 05:52 PM

    ryoichi's Avatar

    That didn't work. PF still fails to delete files after authentication. There are no error messages.

  6. 4 Posted by ryoichi on 23 Mar, 2022 04:16 PM

    ryoichi's Avatar

    I just tried ForkLift to see what it does. It doesn't even ask for a password to authenticate. It only gives you the option to either skip the file or quit altogether. The only app that works is Finder.

  7. 5 Posted by JLH on 24 Mar, 2022 07:30 PM

    JLH's Avatar

    I've reported this also and PF2123 and 2124 have not fixed this. PF10 had no problem with this. For me, when attempting to delete a file/folder that the system requires authentication, I give it my administrative authentication (just like PF10) and the file/folder is deleted, but not with 2123 or 2124. As ryoichi says, Finder has no problem with it. PF2124 asks for authentication and once given PF just sits there without any error messages or any action at all. All I can do is click "Stop". I'm running Monterey 12.3 and PF2124. If I reinstall PF10 all is OK. If this isn't fixed soon, I'll be looking for something else.

  8. 6 Posted by Jay on 24 Mar, 2022 10:59 PM

    Jay's Avatar

    removing and reapply full disk access did NOT fix the problem on my system. As explained above, there is NO error messages.

    When I go to move files that are with the root of the library/application support folder I am asked to authenticate.... the problem is that when I enter my password, nothing happens, I don't get any feedback rather nothing happens.

  9. 7 Posted by Jay on 24 Mar, 2022 11:01 PM

    Jay's Avatar

    use M1 Max Pro / Monterey 12.3

  10. 8 Posted by ryoichi on 28 Mar, 2022 02:10 PM

    ryoichi's Avatar

    I just installed the newest version 2125. It still does not work. Will it ever be fixed?

  11. Support Staff 9 Posted by Path Finder Sup... on 29 Mar, 2022 08:18 PM

    Path Finder Support Team's Avatar

    Hi everyone,

    I have looped in our developer to this thread.

    Could you send us a sample (a snapshot) of Path Finder process in a separate file? This will enable us to analyze what happens with the application.

    Here's how to get it:
    1. Open Path Finder and reproduce the problem. If the problem is dynamic (e.g. unexpected action result), please try reproducing it during the sample collection.
    2. Open Activity Monitor from the /Applications/Utilities folder.
    3. Select Path Finder in the process list. To help making a selection, type "Path Finder" in the Filter field.
    4. Click the Sample Process button in the toolbar - this will open a new window entitled "Sample of Path Finder" and a sample of the process is collected.
    5. Click Save and save the sample file.
    6. Close (Command-W) the Sample window opened in step 2.
    7. Send the sample file saved in step 5 to us.

    Looking forward to your reply!

    Best Regards,
    Mary
    Path Finder Support Team

  12. Path Finder Support Team closed this discussion on 29 Mar, 2022 08:18 PM.

  13. ryoichi re-opened this discussion on 12 Apr, 2022 07:31 PM

  14. 10 Posted by ryoichi on 12 Apr, 2022 07:31 PM

    ryoichi's Avatar

    I just installed 2128. The problem still exists.

  15. 11 Posted by JHerig on 13 Apr, 2022 08:43 PM

    JHerig's Avatar

    I tried to delete a file from Applications. Pathfinder prompted for my password, sent a notification that it was moved to trash, then prompted for a password again. The file was never moved to the trash.

    Included as requested is the sample.

  16. 12 Posted by bulkmail75 on 14 Apr, 2022 04:58 AM

    bulkmail75's Avatar

    Same issue with above, just use finder to delete the file.

  17. Support Staff 13 Posted by Dragan on 14 Apr, 2022 01:00 PM

    Dragan's Avatar

    Hello everyone,

    I sincerely apologise for delay in handling this issue, it came to my attention only recently and I understand how annoying it was for you. I'm really sorry about that…

    Anyway, even though that code haven't changed for quite awhile, it seems that moving to the latest Xcode has broken loading of some frameworks into our privileged helper tools, the one that actually does authenticated file operations (as required by macOS). I've fixed this issue and I've just uploaded fixed version to our server.

    The new (fixed) build version is 2130 and you can download it here, or you can update your current copy using in-app updater, available from the main menu **Path Finder > Check for Updates…" menu item. Please update to this version and see if it fixes your problems with authenticated file operations. If not please let me know.

    Once again, apologies it took this long to fix it. Thanks for your understanding, support and patience.

    Best,
    -- Dragan

  18. 14 Posted by ryoichi on 14 Apr, 2022 02:04 PM

    ryoichi's Avatar

    You recently found out about it? It sounds like somebody dropped the ball somewhere. We've been complaining about it since PF 11 came out.

    Anyway, 2130 solved the problem. I just tried it and it worked!

    Thank you, Dragan 👍

  19. Support Staff 15 Posted by Dragan on 14 Apr, 2022 02:22 PM

    Dragan's Avatar

    Once again, I apologise about the delay 🙁

    I'll free to close this issue and if any of you still see the same problem, just reopen and let me know.

    Apologies again…
    -- Dragan

  20. Dragan closed this discussion on 14 Apr, 2022 02:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac