CPU 100% load on 9.0.4

desperex's Avatar

desperex

05 Nov, 2019 08:58 AM

Hi!
New version, old issues!
The issue hasn't been solved on 8.6, the same is here on 9.0.1
Awaiting resolving the issue within a short term, will ask for refund otherwise.
Sample is attached.

  1. 1 Posted by desperex on 12 Nov, 2019 07:58 AM

    desperex's Avatar

    Hello? A week has passed but I don't see any reply here...

  2. 2 Posted by eins on 12 Nov, 2019 10:01 AM

    eins's Avatar

    Cocoatech released a Twitter message this morning “ Reduce RAM Usage with PF”.
    It’s embarrassing...

  3. 3 Posted by kayazuki on 12 Nov, 2019 12:11 PM

    kayazuki's Avatar

    Hmm.. Ok, so I'm NOT gonna upgrade then..
    A reported problem, no response from the developer..
    Thx for the warning man..

  4. 4 Posted by Les on 12 Nov, 2019 09:25 PM

    Les's Avatar

    Same problem. Had to stop using because bringing my iMac to its knees.

  5. 5 Posted by desperex on 14 Nov, 2019 09:30 AM

    desperex's Avatar

    The same 100% CPU with 9.0.3, anybody going to take a look at that?

  6. Support Staff 6 Posted by Path Finder Sup... on 14 Nov, 2019 10:20 AM

    Path Finder Support Team's Avatar

    Hi all, 

    Sorry for such a delayed reply.

    We are already looking into this issue. So far we've identified a few suspects and working on fixes.

    One for the suspects is the syntax coloring component. Please choose a .txt file, open Preview module preferences (gear button next to its header) and uncheck "Colorize syntax". 

    Also, it may be worth trying to restore defaults for View Settings (cmd+J).
    Make sure to have "Calculate all sizes" unchecked here. 

    Sorry for the inconvenience. Please let me know how it goes/if the issue persists.

    Best Regards,
    Jordan
    Path Finder Support Team

  7. Path Finder Support Team closed this discussion on 14 Nov, 2019 10:20 AM.

  8. Les Fuchs re-opened this discussion on 21 Nov, 2019 07:03 PM

  9. 7 Posted by Les Fuchs on 21 Nov, 2019 07:03 PM

    Les Fuchs's Avatar

    Hi Jordan,

    Recently installed PF 9.0.3, and it’s still using 100% of my CPU.

    I tried to follow your suggestion (Please choose a .txt file, open Preview module preferences (gear button next to its header) and uncheck "Colorize syntax". ), but I couldn’t figure out what you meant. Didn’t see a header or gear button when I opened the .txt file in PF.

    I did restore View Settings defaults, but that didn’t help. I couldn’t find the “calculate all sizes” command.

    However, I may have just stumbled upon a relevant issue. I was about to quit PF, and I happened to notice a small PF window at the bottom, left of my open PF screen. It was showing a postage-stamp size version of the PF left side bar. I clicked on the close button and received a dialog box that said something to the effect of “Do you want to close this PF window? It has 256 open tabs.” I clicked “yes”, the miniature window disappeared and PF started operating normally…not super-sluggish as it had been operating. I checked Activity Monitor and found an item named “https://Cocoatch.com <https://cocoatch.com/>” using ~33% of my CPU with nothing else above it (i.e. using more CPU cycles).

    Is the above url a result of PF “phoning home”? If so, how can I disable it? Also, I have no idea where the miniature version of the PF screen with 256 open tabs came rom. I normally have only a few tabs open.

    I just noticed something else. A new miniature window popped up again, and this time I clicked on the green, expand button. When I did, it showed the “Purchase” opening screen as it had when I first launched the 9.0.3 PF trial (still have about half of trial period remaining). I clicked on “continue trial” (or something to that effect) and closed the extra PF desktop that I had expanded.

    Please let me know what you make of this bizarre behavior.

    Cheers,
    Les

  10. 8 Posted by Les Fuchs on 21 Nov, 2019 07:17 PM

    Les Fuchs's Avatar

    I checked Activity Monitor after sending you the email below, and the url no longer appears and PF is hardly using any CPU cycles. As I said below, bizarre.
    ________________________________________________________________

    Hi Jordan,

    Recently installed PF 9.0.3, and it’s still using 100% of my CPU.

    I tried to follow your suggestion (Please choose a .txt file, open Preview module preferences (gear button next to its header) and uncheck "Colorize syntax". ), but I couldn’t figure out what you meant. Didn’t see a header or gear button when I opened the .txt file in PF.

    I did restore View Settings defaults, but that didn’t help. I couldn’t find the “calculate all sizes” command.

    However, I may have just stumbled upon a relevant issue. I was about to quit PF, and I happened to notice a small PF window at the bottom, left of my open PF screen. It was showing a postage-stamp size version of the PF left side bar. I clicked on the close button and received a dialog box that said something to the effect of “Do you want to close this PF window? It has 256 open tabs.” I clicked “yes”, the miniature window disappeared and PF started operating normally…not super-sluggish as it had been operating. I checked Activity Monitor and found an item named “https://Cocoatch.com <https://cocoatch.com/>” using ~33% of my CPU with nothing else above it (i.e. using more CPU cycles).

    Is the above url a result of PF “phoning home”? If so, how can I disable it? Also, I have no idea where the miniature version of the PF screen with 256 open tabs came rom. I normally have only a few tabs open.

    I just noticed something else. A new miniature window popped up again, and this time I clicked on the green, expand button. When I did, it showed the “Purchase” opening screen as it had when I first launched the 9.0.3 PF trial (still have about half of trial period remaining). I clicked on “continue trial” (or something to that effect) and closed the extra PF desktop that I had expanded.

    Please let me know what you make of this bizarre behavior.

    Cheers,
    Les

  11. 9 Posted by Les Fuchs on 24 Nov, 2019 08:28 PM

    Les Fuchs's Avatar

    Hi Jordan,

    It happened again. PF was back up to 100% CPU usage. However, I think I finally figured out what’s going on. I looked at the PF screen when I noticed everything slowing down and noticed there we’re numerous tabs open again (see below).

    I selected close all tabs and got the following message:

    Following that, I went into Preferences and “Reveal in new tab” to "Reveal in existing window”. That seems to have solved the mystery…hopefully. I certainly wasn’t choosing to open 257 new tabs, but, apparently, PF was automatically doing this based on my Preferences selection.

    You might want to check this out a I’ve seen others reporting the same 100% CPU usage problem with PF.

    Cheers,
    Les
    _______________________________________________________________

    I checked Activity Monitor after sending you the email below, and the url no longer appears and PF is hardly using any CPU cycles. As I said below, bizarre.
    ________________________________________________________________

    Hi Jordan,

    Recently installed PF 9.0.3, and it’s still using 100% of my CPU.

    I tried to follow your suggestion (Please choose a .txt file, open Preview module preferences (gear button next to its header) and uncheck "Colorize syntax". ), but I couldn’t figure out what you meant. Didn’t see a header or gear button when I opened the .txt file in PF.

    I did restore View Settings defaults, but that didn’t help. I couldn’t find the “calculate all sizes” command.

    However, I may have just stumbled upon a relevant issue. I was about to quit PF, and I happened to notice a small PF window at the bottom, left of my open PF screen. It was showing a postage-stamp size version of the PF left side bar. I clicked on the close button and received a dialog box that said something to the effect of “Do you want to close this PF window? It has 256 open tabs.” I clicked “yes”, the miniature window disappeared and PF started operating normally…not super-sluggish as it had been operating. I checked Activity Monitor and found an item named “https://Cocoatch.com <https://cocoatch.com/>” using ~33% of my CPU with nothing else above it (i.e. using more CPU cycles).

    Is the above url a result of PF “phoning home”? If so, how can I disable it? Also, I have no idea where the miniature version of the PF screen with 256 open tabs came rom. I normally have only a few tabs open.

    I just noticed something else. A new miniature window popped up again, and this time I clicked on the green, expand button. When I did, it showed the “Purchase” opening screen as it had when I first launched the 9.0.3 PF trial (still have about half of trial period remaining). I clicked on “continue trial” (or something to that effect) and closed the extra PF desktop that I had expanded.

    Please let me know what you make of this bizarre behavior.

    Cheers,
    Les

  12. 10 Posted by desperex on 29 Nov, 2019 09:14 AM

    desperex's Avatar

    The same on 9.0.4

  13. 11 Posted by Prado on 01 Dec, 2019 10:11 PM

    Prado's Avatar

    Hi,
    this is being caused by concurrent routine code trying to draw simultaneously on PathFinder window at the same time, it is a thread racing problem. Thus leading to 100% CPU usage.

    FIX it: [in 2 steps]

    1) Open PathFinder -> Preferences -> Appearance and DISABLE [Uncheck] "Use System colors" .

    2) For every module that you are using, go to the configuration of each one, and select "Use Translucent background" for each of the modules you use.

    Close PathFinder via menu PathFinder -> "Quit Pathfinder"
    Re-open it.
    Problem will be gone forever.

    PS: You may need to customize some colors [if you are using dark interface], and you can easily do it on PF Preferences -> Appearance -> Color Editor.

    Post your feedbacks

  14. 12 Posted by desperex on 03 Dec, 2019 04:17 PM

    desperex's Avatar

    Hi Prado, I wanted seamless Catalina support, your solution to the issue makes me want to go back to version 8 the least, with manual color set to fit Catalina dark mode.

    Thanks for you advice anyway, you've put alot of effort to overcome app solution design.

    Now I'm totally confident that dev team lacks enough tech expertise.
    You know how to solve it, they don't.

  15. 13 Posted by jarch on 03 Dec, 2019 05:25 PM

    jarch's Avatar

    I just started to test PF to see if I can use it to replace Adobe Bridge, and experienced the same problem. My computer get stalled after trying to browse some pictures.
    The trial is version 9.0.5 (2026).
    Seems that this problem is quite old and has not been resolved yet.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Sample_of_Path_Finder_05.11.19.txt 301 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac