Purchase v9 window is blank

Peter's Avatar

Peter

02 Nov, 2019 03:42 PM

I've been a (mostly) happy Pathfinder user for several years, and I've just downloaded 9.0.1. When I go to purchase it by clicking the little 'Buy Now' link, and click the 'Purchase' button, I just get presented with a blank screen (see screenshot). Any ideas how I purchase the upgrade?

I'm running macOS Sierra 10.12.6

Thanks,
Peter

Showing page 2 out of 2. View the first page

  1. Path Finder Support Team closed this discussion on 08 Nov, 2019 03:34 PM.

  2. Path Finder Support Team re-opened this discussion on 08 Nov, 2019 03:35 PM

  3. Support Staff 31 Posted by Path Finder Sup... on 08 Nov, 2019 03:35 PM

    Path Finder Support Team's Avatar

    Hi Everyone,

    We are investigating this issue currently.

    It seems to only happen on older versions of macOS. Does anyone experience this issue on macOS 10.13 or later?

    Looking forward to your reply.

    Best Regards,
    Jordan 
    Path Finder Support Team

  4. Path Finder Support Team closed this discussion on 08 Nov, 2019 03:35 PM.

  5. Path Finder Support Team re-opened this discussion on 08 Nov, 2019 03:37 PM

  6. 32 Posted by Wolfram Guenthe... on 08 Nov, 2019 03:52 PM

    Wolfram Guenther's Avatar

    Hi Jordan,
    everything ist fine on my Mac Os Mojave System.

    Best regards
    Wolfram

  7. 33 Posted by mullerlp on 08 Nov, 2019 04:01 PM

    mullerlp's Avatar

    Same problem here.
    MacOS 10.13.3
    iMac mid 2011

  8. 34 Posted by wade on 08 Nov, 2019 11:09 PM

    wade's Avatar

    when PF opens and you try to buy the blank window just keeps expanding every time you hit the button

    10.13.6

  9. 35 Posted by Wolfram Guenthe... on 09 Nov, 2019 07:53 PM

    Wolfram Guenther's Avatar

    Hi Pathfinder Team,
    it works now.

    Thank you and have a nice day
    Wolfram

  10. 36 Posted by Jose on 10 Nov, 2019 08:29 AM

    Jose's Avatar

    macOS Catalina, 10.15.1

    PF upgraded to 9., problem still remains exactly same since my complain (Nov 2, day I purchase (forced) this update). For when a resolution ?

  11. 37 Posted by kimhorn on 10 Nov, 2019 08:55 AM

    kimhorn's Avatar

    The problem is they are now breaking the law. It is illegal to sell products that do not work.
    I have legally paid for a product that no longer works.

  12. 38 Posted by Alexander on 10 Nov, 2019 11:35 AM

    Alexander's Avatar

    After updating. Mac 0S X 10.11.06 and Path Finder 9.0.2 is working for me.
    Thanks! alexander

  13. 39 Posted by Peter on 10 Nov, 2019 12:19 PM

    Peter's Avatar

    Well for some reason it suddenly started working for me and I can now see the contents of the upgrade window. I was able to paste my license key in and I'm all sorted now.

    Did something change at the cocoatech end? No changes my end that I can think of.

    thanks,
    Peter

  14. 40 Posted by LWks on 10 Nov, 2019 05:38 PM

    LWks's Avatar

    Yup, same thing here -- I've been occasionally clicking on the purchase button to see if the problem had been fixed (and, most of the time, no, it had not been) but, then, out of nowhere, the upgrade window suddenly started working. I was able to add license and am now back up and running.

    Like Peter, I'm also darn certain that there were no changes, at my end, that would have caused it start working and am assuming that CocoaTech finally fixed something at their end.

    MacPro desktop under OS 10.12.6

  15. 41 Posted by Ally on 10 Nov, 2019 10:41 PM

    Ally's Avatar

    Same here - no obvious changes at my end but PF9 upgrade / registration window now working successfully.

    MacBook Pro (Retina, Mid 2012), macOS Sierra 10.12.6

  16. 42 Posted by john.halter on 11 Nov, 2019 04:01 PM

    john.halter's Avatar

    My Purchase window was initially blank, but then did populate. However, I now have a "Free Trial - Buy Now!" on my desktop! I've already bought the upgrade and activated the license. I'm on Mojave 10.14.6 (18G1012).

  17. 43 Posted by Ballonsight on 12 Nov, 2019 07:35 PM

    Ballonsight's Avatar

    I just tried to try (!) Path Finder 9, freshly downloaded. I'm coming from Path Finder 7, which I'm still running stably on 10.13.6. On launch, PF9 greets me with an oversized "Purchase" window that briefly shows (nothing but) a Path Finder logo that quickly moves to the bottom and off the screen. The window is then blank. I cannot close it, it wiggles wildly when I drag it across the screen, and no other Path Finder function works (except quitting via the Dock icon).

    I though this might be an artifact from my PF7 installation, so I trashed everything Path Finder via AppCleaner and retried. Same show. I cannot even start up the application.

    I've always loved Path Finder and considered it essential software, so even after having a similar experience with PF8 and watching issue after issue pile up here, I thought I'd give version 9 another try. But seriously, this is simply ridiculous. Two major new versions and the app won't even launch!

    If you want my money, make this f'ing thing work again before introducing "new features" and switching to shorter upgrade cycles that would cost me money every year. Up until PF7, this was a serious, highly capable and largely very stable workhorse program. Since PF8, it is little more than a clown show. I'll be staying on PF7, and when that stops working due to macOS updates, unless the "new" Path Finder is fundamentally improved by then, I'll be a lost customer.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • PF_9_Upgrade_Window.jpeg 44.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac