Memory leak if "large" text file is selcted

Thorsten's Avatar

Thorsten

28 May, 2019 09:48 AM

I had this issue in 8.0.X already (I'm on 8.5.1 now) and hoped it will sort itself out with 8.5.X

If I select a "large" textfile => More than 20MB, XML, CSV, JSON, ... PathFinder fils up RAM until the hole system stops working. It doesn't neither help to deselect the file, RAM keeps filling. Screen recording: https://jumpshare.com/v/2pOR0FnRMEtVX9jNB5sG

  1. 1 Posted by pontus.amberg on 28 May, 2019 10:11 PM

    pontus.amberg's Avatar

    I'm not sure but I think that I have encountered the same bug but with ZIP-files in 8.5.1.

    I tried to Compress a large package/folder (*.pvm package from Parallels) and when I
    returned to the computer PathFinder had gone unresponsive since it had allocated
    more than 60+ GB of memory! The compressed file was 60+ GB so I assume that PathFinder selected the resulting file of the compression and that triggered the same problem. I have the Preview module active for selected files, might that be the cause?

  2. Support Staff 2 Posted by Path Finder Sup... on 29 May, 2019 09:32 AM

    Path Finder Support Team's Avatar

    Hi Thorsten, 

    Could you send us a sample (a snapshot) of PathFinder process in a separate file - this will enable us to analyze what happens with the application. Here's how to get it: 

    1. Open Path Finder and reproduce the problem. 
    2. Open Activity Monitor from the /Applications/Utilities folder. 
    3. Select Path Finder in the process list. To help making a selection, type "Path Finder" in the Filter field. 
    4. Click the Sample Process button in the toolbar - this will open a new window entitled "Sample of Path Finder" and a sample of the process is collected. 
    5. Click Save and save the sample file. 
    6. Close (Command-W) the Sample window opened in step 2. 
    7. Send the sample file saved in step 5 to us. 

    Then, please choose a .txt file, open Preview module preferences (gear button next to its header) and uncheck "Colorize syntax". 

    Also, it may be worth trying to restore defaults for View Settings (cmd+J).
    Make sure to have "Calculate all sizes" unchecked here. 

    Let us know if this helps. Looking forward to your reply. 

    Best Regards,
    Jordan
    Path Finder Support Team

  3. Path Finder Support Team closed this discussion on 29 May, 2019 09:32 AM.

  4. Thorsten re-opened this discussion on 29 May, 2019 09:42 AM

  5. 3 Posted by Thorsten on 29 May, 2019 09:42 AM

    Thorsten's Avatar

    I attached the sample data

  6. 4 Posted by Thorsten on 29 May, 2019 09:48 AM

    Thorsten's Avatar

    I unchecked "Colorize syntax" and now it works, PF stays low on memory. Good workaround, thank you!

  7. Path Finder Support Team closed this discussion on 29 May, 2019 09:49 AM.

  8. Path Finder Support Team re-opened this discussion on 29 May, 2019 09:49 AM

  9. Path Finder Support Team closed this discussion on 24 Jun, 2019 06:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac