Closing a window frequently causes PF to hang

Vaughan's Avatar


04 Apr, 2019 02:24 PM

The title says pretty much what the problem is, and it's one which I've had for quite some time now. Fairly regularly I'll close a PF window (using Cmd-W) and I'll get the Spinning Ball of Death. Waiting doesn't help and my only choice is to force quit PF and restart it. I can't determine any pattern to these freezes. Needless to say, this is extremely annoying and has, on occasion, even sent me back to the built-in MacOS Finder.

  1. Support Staff 1 Posted by Path Finder Sup... on 05 Apr, 2019 05:48 PM

    Path Finder Support Team's Avatar

    Hi Vaughan, 

    Do you get crash/hang reports after this happens? Would you be able to forward those to us?

    Please, also follow the instruction and check if the issue still persists: 

    1. Make sure that Path Finder is located in the Applications folder
      (in case you are using macOS Mojave) Use System Preferences > Security & Privacy > grant Full Disk Access to Path Finder

    2. Open your terminal and paste the following command to check if Path Finder has been slapped with the quarantined extended attribute:
      xattr /Applications/"Path"

    3. If you see returned as output from that last command, then go ahead and run this next command:
      xattr -d /Applications/"Path"

    You won't get any feedback or output from that command, but that's okay because you can just run the first command again to see for yourself if the attribute shows up again. It shouldn't, and now Path Finder is freed from Apple quarantine jail. Restart your PathFinder now. 

    Don't hesitate to contact us should any questions arise. 

    Best Regards,
    Path Finder Support Team 

  2. Path Finder Support Team closed this discussion on 05 Apr, 2019 05:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac