There is no application available to open the document ...

Larry's Avatar

Larry

24 Apr, 2013 05:41 PM

These are PDF documents. They have the ".pdf" extension in the filename, but under "Kind" in the PF window, there's "PDF", not "Portable Document Format (PDF)" as there is for other files. If I control-click one of these files, under "open with" Skim is selected as default, as it should be, because I set this option with the Finder, and Skim is installed and working, because I can open these files using Skim's menus.

What's up? I am just trying PF out, and had high expectations, and I'm very disappointed right now.

Larry

  1. 1 Posted by Damazio on 24 Apr, 2013 06:24 PM

    Damazio's Avatar

    Hi Larry.

    What is the problem exactly? You can't open those PDFs by double clicking them in Path Finder? What options do you get under the Open With menu?

  2. 2 Posted by Larry on 25 Apr, 2013 01:02 AM

    Larry's Avatar

    If I double-click, hit return, ctl-click -> open with -> Skim all give the same error

    I went back tot the finder, and lo and behold, double-clicking these files there doesn't open them either.

    Back to PF, tried to open different PDF file, one that should open in Preview, and I get the same error, "There is no application..."

    Quit PF, double-clicked other PDF file in finder window - now no PDF file will open, period. PF has changed something.

    In PF, ctl-clicked an MP3 file, open with Vox, worked.

  3. 3 Posted by Damazio on 25 Apr, 2013 02:09 AM

    Damazio's Avatar

    Try to Get Info on that PDF, reset the Open with section to Preview.app and click on Change all. Quit and relaunch Path Finder and change it back to Skim.

  4. Damazio closed this discussion on 29 Apr, 2013 10:31 AM.

  5. Larry re-opened this discussion on 30 Apr, 2013 01:22 AM

  6. 4 Posted by Larry on 30 Apr, 2013 01:22 AM

    Larry's Avatar

    I tried your suggestions. It sorta worked, but not really. Can't open most any PDFs anymore, even ones that used to open just fine in Preview, that show the Preview icon, with correct previews in the PF preview pane, and that show correctly in quick-look. I had similar problems with some mp4 files.

    After I tried your suggestion, I was getting the OsX-generated "can't open this file because it's from an unidentified developer" error on some of the PDFs. I turned off that option in system prefs, now it's set to open any file from anyone, but I'm getting the "there is no application available..." error still.

  7. 5 Posted by Larry on 30 Apr, 2013 02:06 AM

    Larry's Avatar

    I quit all apps, rebuilt launch services (using MainMenu), still doesn't work in PF or Finder anymore. Didn't have this problem until I installed PF.

  8. 6 Posted by Damazio on 30 Apr, 2013 09:52 AM

    Damazio's Avatar

    I'm just saying no one ever reported such issue before but there's only one way to find out.
    Firstly, you can try to create a new user account in System Preferences and see if the problem persists. You can also try to repair permission, just in case.

    If nothing changes, try to uninstall Path Finder and reboot.

  9. Damazio closed this discussion on 01 May, 2013 03:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac