Keyboard Commands are not Editable in PF6

jacob's Avatar

jacob

20 Apr, 2012 02:13 PM

I am not able to edit the keyboard commands in the application Preferences in PF6. For example I hit cmd+, to open the Preferences dialog box, hit the Features tab, select Keyboard from the side menu, hit the arrow next to “File” to expand the section, hit the arrow next to “New Browser” to expand the section, and attempt to edit the “New Browser” option to change it from cmd+n to nothing, or something else more obscure, but it will not activate. Meaning: Single or double-clicking on the words “New Browser”; single or double-clicking on the space under the “Command” column; or selecting the entry and hitting return, enter, delete, or backspace does nothing. There is no response from the application.

I also wanted to change “New Folder…” to cmd+n.

I was able to make the change using the OS X System Preferences, which as you can see from the double entries of “New Browser,” isn’t ideal. I’ve attached an illustration of the after.

Thank you.

Jacob

  1. 1 Posted by jacob on 20 Apr, 2012 02:16 PM

    jacob's Avatar

    I’ll try uploading the image again.

    Jacob

  2. Support Staff 2 Posted by Dragan on 20 Apr, 2012 03:24 PM

    Dragan's Avatar

    Rows it the list of menu commands are not clickable, so just don't try to click them. Below the table you can read: "Select a menu item and hit a command key sequence to modify. Hit the delete key to clear".

    So, just do it like that; select e.g. "New Browser" row and just hit delete (or backspace) and the shortcut will be cleared and not active any more. If that doesn't happen, please report back, because then something went wrong. Also, if you don't want to clear the shortcut, but just to change it to something else, when a row is selected just type that command sequence. E.g. to change "New Browser" command shortcut to cmd+ctrl+shift+n just select "New Browser" and press all those four keys together, and it will change (see attached image). If you try to assign already used key sequence, you'll see a beep and nothing will change.

  3. Dragan closed this discussion on 20 Apr, 2012 03:24 PM.

  4. jacob re-opened this discussion on 20 Apr, 2012 03:34 PM

  5. 3 Posted by jacob on 20 Apr, 2012 03:34 PM

    jacob's Avatar

    I’m sorry in my attempt to give a though explanation I glossed over that part. No, I initially followed the directions, which didn’t work for me. That is why I tried all the other things. The list just isn’t responsive on my machine, even after a restart. Sorry for the confusion.

    Jacob

  6. 4 Posted by MsWhee on 13 May, 2012 11:47 PM

    MsWhee's Avatar

    I use PF6 v6.0.0 (1232) on my MacBook Pro with Mac OS X 10.7.4 Build 11E53.

    I have the same problem as Jacob's one, as for me, I can't edit the menu of "Close Window (cmd+W)". I tried first to delete the key sequence by delete/backspace key but didn't work. Neither did pressing Command and any keys.

    Is this a bug or any idea for setting?
    Thank you for your help...

  7. 5 Posted by Damazio on 30 Jun, 2012 03:18 PM

    Damazio's Avatar

    I think some key combinations are locked on purpose (or by OS X itself), like Command + W/Y/I/S.

  8. Damazio closed this discussion on 30 Jun, 2012 03:18 PM.

  9. Damazio re-opened this discussion on 17 Jul, 2012 10:11 AM

  10. 6 Posted by Damazio on 17 Jul, 2012 10:14 AM

    Damazio's Avatar

    Jacob, I closed this thread without fully understanding that... you still can't edit any combination key. Does it still happen on v6.0.4? What OS X version are you on?

  11. 7 Posted by jacob on 17 Jul, 2012 12:58 PM

    jacob's Avatar

    Damazio, It works perfectly now on v6.0.4, and I’m running OS X 10.6.8. The update also fixed the issue I was having the “Select…” dialog not working, so I’m ecstatic! Thank you so much for the follow up!

  12. 8 Posted by Damazio on 17 Jul, 2012 02:06 PM

    Damazio's Avatar

    Great news.

  13. Damazio closed this discussion on 17 Jul, 2012 02:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac