Favorite locations open in text editor

bhertziger's Avatar

bhertziger

19 Apr, 2012 11:21 PM

I've had this problem with version 5 and 6 where I have some saved SMB locations that when I click on them in the left bar in Pathfinder they just open in a text editor window (part of pathfinder) as an XML document. In the past, Pathfinder would use the information to reconnect my network location. I had tried recreating them in the past, but the new ones behave the same as existing locations.

How can I fix it so favorites of network locations actually connect again, or is there a preferred method for doing this now.

Running on an iMac (24" early 2008) with OS X 10.7.3

  1. 1 Posted by jjwebster on 20 Apr, 2012 03:41 PM

    jjwebster's Avatar

    I'm having the exact same problem. I emailed Cocoatech support and they suggested recreating the Favorites, but as bhertziger reports (and I can confirm), that does not work.

    I can't say for sure, but I believe these were working after the Lion update and they have stopped working within the last two months. Was there a PathFinder update during that time?

    Running on MacBook Pro (17" mid 2009) with OS X 10.7.3.

  2. 2 Posted by jjwebster on 20 Apr, 2012 04:27 PM

    jjwebster's Avatar

    Hmm… perhaps it is this simple: In PathFinder 6.0, I opened Perferences and unchecked TextEdit documents box under "Open with PathFinder:". Now, the Favorites seem to be working. I haven't gone back to PathFinder 5.8.1 to see if a similar solution would work. What I don't understand is that I never manually changed that option to "break" the Favorites in the first place. Perhaps an update did it?

  3. 3 Posted by bhertziger on 20 Apr, 2012 06:21 PM

    bhertziger's Avatar

    I tried that change and it did resolve the issue. The favorites were treated as objects and not text files. I don't recall making this change, so perhaps a default changed along the way that could account for it?

    Good find, jjwebster!

  4. 4 Posted by Damazio on 28 Apr, 2012 02:28 AM

    Damazio's Avatar

    This is strange indeed because it's not happening to me with or without the option jjwebster mentioned but if I call a Get Info on a alias (favorites are aliases in the user library folder) I get TextEdit on the Open with section. They still open well in Path Finder (files or folders) but Finder doesn't have an Open with for aliases, which seem the correct way oh handling them. What are you guys getting on the Open with section?

  5. Damazio closed this discussion on 01 May, 2012 03:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac