Certificate Issues

Mike Price's Avatar

Mike Price

17 Aug, 2018 10:53 AM

I realize that both of these issues have been reported to the Cocoatech developers, but I wanted to reiterate the post made by Ingo on August 12th as I observe the same issues. Actually, I have has the nmblookup issue with certificate used for all of the v8 versions.
Hopefully in letting you know that more people have these issues, will escalate the priority of publishing a fix......and (IMHO) the website cert should be fixed TODAY !! Going to the support site and being presented with a "this site may not be secure and somebody may be impersonating support.cocoatech.com", does not make Cocoatech look very good (or competent).

Since there is no need to re-invent the wheel here. Ingo did a great job of that, I am simply gong to repost (and add an attachment showing the error).

Ingo
Aug 12, 2018 @ 08:05 AM
Hey there, I updated to PF 8.1. Afterwards little snitch blocked the samba connection pathfinder tried to open, because of a wrong code signature in /Applications/Path Finder.app/Contents/Frameworks/PathFinderNetwork.framework/Versions/A/Helpers/nmblookup

Then, when I tried to open https://support.cocoatech.com I run into a certificate error, since your certificate shows the wrong Domain Name.

Please explain what is going on there. I am in general a happy and more than once paying customer, but fishy TLS certificates and code signatures are not acceptable in 2018 anymore.

  1. Path Finder Support Team closed this discussion on 17 Aug, 2018 02:08 PM.

  2. Path Finder Support Team re-opened this discussion on 17 Aug, 2018 02:08 PM

  3. 1 Posted by mark on 18 Aug, 2018 02:57 PM

    mark's Avatar

    I'm seeing this on https://support.cocaotech.com/ in Chrome.

    The invalid certificate belongs to tenderapp - who as far as I can see are the support-software providers, which presumably means they develop/ host/ maintain/ staff this support forum for Cocoatech,

    Agree with the points above. We're using PF to handle all kinds of local and remote server traffic, running terminal from it, etc etc. If the File Manager and its Developers' support site have invalid certificates this doesn't fill me with confidence in the rigour of the dev/commit methodology behind the current incarnation of the product.

  4. Path Finder Support Team closed this discussion on 18 Aug, 2018 03:40 PM.

  5. Path Finder Support Team re-opened this discussion on 18 Aug, 2018 03:40 PM

  6. 2 Posted by rob on 21 Dec, 2018 11:19 PM

    rob's Avatar

    It's 2018.
    There's no excuse for this.
    BTW, on a Mac using Safari, the site cannot be reached.
    After clicking "Visit the site" it just re-prompts warning that "This connection is not private".

    OS X 10.14.3 beta
    Safari 12.0.3

  7. 3 Posted by Angelika on 22 Dec, 2018 05:35 AM

    Angelika's Avatar

    Same problem here: Little snitch blocking pathfinder: “nmblookup” has an unacceptable code signature. It was signed using a certificate that does not come from Apple.
    macOS 10.13.6

    Any ETA when this will be fixed since the bug has already been reported in August?

  8. Path Finder Support Team closed this discussion on 22 Dec, 2018 11:53 AM.

  9. Path Finder Support Team re-opened this discussion on 22 Dec, 2018 11:54 AM

  10. 4 Posted by Grigori Gazaria... on 28 Dec, 2018 06:04 PM

    Grigori Gazarian's Avatar

    Same here, on 10.14.2. Pretty annoying.

  11. 5 Posted by phantom.helix on 28 Dec, 2018 06:44 PM

    phantom.helix's Avatar
  12. Path Finder Support Team closed this discussion on 29 Dec, 2018 07:39 AM.

  13. Path Finder Support Team re-opened this discussion on 29 Dec, 2018 07:39 AM

  14. 6 Posted by Kris on 30 Dec, 2018 05:16 PM

    Kris's Avatar

    Persistent error over the last few days over the last few days with little snitch throwing this same error. If users do not have little snitch installed then they are completely unaware of the invalid signature. I'm not trying to connect to your website, only use the program (Which I love, but am concerned that this issue has been left unpatched for so long.

    Is there a reason the code is not signed correctly? How do I know I don't have an unauthorized version?

  15. Support Staff 7 Posted by Path Finder Sup... on 31 Dec, 2018 10:28 AM

    Path Finder Support Team's Avatar

    Hi Mike, 

    Thanks for reporting this issue!

    We've already submitted it to our developers, sorry for the inconvenience. 
    It may take some time, unfortunately, to fix this issue, as there are many others. 

    Make sure to let us know should any further questions arise. 

    Best Regards, 
    Jordan
    Path Finder Support Team 

  16. Path Finder Support Team closed this discussion on 31 Dec, 2018 10:28 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac