Thumbnails not refreshing

andre's Avatar

andre

19 Dec, 2012 04:14 AM

When creating new image files and looking at a folder in PathFinder during the generation of the files, the newly created files thumbnails don't always show even after Reloading the view. They eventually appear but after a long time, whereas they appear on-the-fly in Finder.

It only happens if the file appears in the window, in thumbnail mode, while it is created. If the file was out of the viewport or in a folder not currently showing, the thumbnail is generated properly.

  1. 1 Posted by andre on 19 Dec, 2012 04:16 AM

    andre's Avatar

    My screenshot does not seem to have been added... here it is...

  2. 2 Posted by Damazio on 22 Dec, 2012 03:59 PM

    Damazio's Avatar

    Andre, sometimes this also happens in Finder and it's not a bug in Path Finder.
    Try to enter inline rename mode on one of those thumbs (long click on the filename) and press Return without changing the name or relaunch Path Finder, and see if it fixes it.
    Please report back if the "fake-renaming" works so I notify Dragan (dev) about this discussion. Perhaps he can think of some kind of work-around.

  3. 3 Posted by andre on 10 Jan, 2013 01:49 PM

    andre's Avatar

    1 - The fake rename workaround does not work.
    2 - When I have a Path Finder window opened aside to a Finder window while images get generated (both in thumbnail view), I see the thumbnail appearing in the Finder window but not in the PathFinder window. This happens all the time when the file is created while PathFinder is displaying the containing folder in thumbnail view.

    The only workaround I have found it to quit PathFinder and launch it back.

  4. 4 Posted by Damazio on 10 Jan, 2013 01:58 PM

    Damazio's Avatar

    Andre, just one more test. When the thumbs fail to refresh, go into View > Show View Options and try to increase the icon size.

  5. 5 Posted by andre on 10 Jan, 2013 02:00 PM

    andre's Avatar

    It does work. As soon as I touch the slider, the images appear.

  6. 6 Posted by Damazio on 10 Jan, 2013 02:15 PM

    Damazio's Avatar

    Thanks. Let's see if Dragan figures something out.

  7. 7 Posted by Damazio on 10 Jan, 2013 03:20 PM

    Damazio's Avatar

    Andre, I found there is a ticket already submitted on this issue (#190). I'll attach it to this discussion once Tender behaves (it's returning an error for the past few days).
    We'll notify you when there's an update.

  8. 8 Posted by Damazio on 14 Jan, 2013 11:14 AM

    Damazio's Avatar

    I attached the ticket and we'll re-open when there's an update on this, Andre.

  9. Damazio closed this discussion on 14 Jan, 2013 11:14 AM.

  10. andre re-opened this discussion on 14 Jan, 2013 12:33 PM

  11. 9 Posted by andre on 14 Jan, 2013 12:33 PM

    andre's Avatar

    Great Thanks! One more thing. I was copying stuff from one drive to another yesterday and I saw pictures appearing in thumbnail mode, where the thumbnails were properly displayed this time. It might be that this issue only happens under some conditions but I cannot tell which. When I have the problem, it's when I export jpegs from Adobe Lightroom. I don't know if it's Lightroom that's doing something weird, not very likely but...

  12. 10 Posted by Damazio on 14 Jan, 2013 12:52 PM

    Damazio's Avatar

    Well, it's known that Adobe software doesn't play nice in other situations so there may be a connection. Thanks for the report, Andre, it may be useful to the devs.

  13. Damazio closed this discussion on 14 Jan, 2013 12:52 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac