Help! Arrow keys are moving files / folders to other pane

Bryan's Avatar

Bryan

13 Dec, 2012 12:46 AM

I'm not sure if this is a new feature or a bug but it's been causing a lot of headache today at the office. We were navigating through folders in PathFinder with dual pane open as normal and our folders just started disappearing. At first we thought it was an issue with newer installed dropbox sync app....but throughout the day we noticed this problem in regular folders. It seems like when we hit some combination of the up or down arrow keys in dual pane it's performing a move operation which is completely unintended and moving things around the the wrong places. Help it stop! or info on how to disable if this was supposed to be a feature.

  1. 1 Posted by Damazio on 13 Dec, 2012 01:59 PM

    Damazio's Avatar

    Bryan, the only thing I can think of is the new feature introduced in 6.1.2 to Copy/Move to Other Pane. You can find those in the Commands menu. Now, the default hotkeys should be single F keys but you can check them in the menu as well.
    You can clear the hotkeys in Preferences > Features > Keyboard so you don't hit them by mistake.

    Let us know if it helps.

  2. 2 Posted by Bryan on 13 Dec, 2012 02:30 PM

    Bryan's Avatar

    The Copy to Other Pane is set to F5. I'd also tried just deleting my plist file completely in my user directory and still same deal. This issue doesn't seem to be very consistent but pretty close. When in dual pane I'll use the arrow keys to navigate up / down. The general pattern I'm seeing is I hit down once or twice then up a couple times and then every subsequent Up action is moving files from the pane I'm in to the other. I'll keep trying to play around with some things. Odd.

  3. 3 Posted by Damazio on 13 Dec, 2012 03:00 PM

    Damazio's Avatar

    Pretty odd. The up/down arrow keys should only move the selection around. At most, it could happen if a modifier key was pressed at the same time (Command, Option).
    If you find a clear pattern, please do let us know.

  4. Damazio closed this discussion on 17 Dec, 2012 12:50 PM.

  5. Bryan re-opened this discussion on 18 Dec, 2012 07:32 PM

  6. 4 Posted by Bryan on 18 Dec, 2012 07:32 PM

    Bryan's Avatar

    This issue is not resolved it's still an ongoing problem and it's not consistent and it's making it impossible to work with Path Finder.

    For an immediate resolution is there a way I can downgrade to the previous release?

    I had completely shut the machine down and restarted Path Finder and all seemed ok for a little while though it keeps happening. When I'm hitting the Up key ONLY nothing else is being held down it's moving entire folders between panes and causing a lot of major issues when folders are just missing. Especially when working in web / development directories.

    This issue is happing both with an external keyboard and built-in to my MBP.

    Any other suggestions?

  7. 5 Posted by Bryan on 18 Dec, 2012 07:38 PM

    Bryan's Avatar

    I take that back about same issues on the built-in keyboard. The built-in keyboard on my mbp does NOT seem to cause the same issue. However, external keyboards, I'm using the larger mac external keyboard w/ USB when using that the issues above are consistent. Though this has never been an issue until the latest version of Path Finder was installed.

  8. 6 Posted by Damazio on 18 Dec, 2012 08:08 PM

    Damazio's Avatar

    The closet previous version is 6.0.6 (Snow Leopard) which will also work in Lion and above I think.

    I'll notify Dragan (dev) about this discussion. Maybe he has an external keyboard to test it.

  9. 7 Posted by Damazio on 18 Dec, 2012 08:14 PM

    Damazio's Avatar

    In the mean time, try to clear the hotkeys in Preferences > Features > Keyboard > Dual Browser for Copy/Move/Compress/Decompress to X Pane (select each one and press the Delete key) even if they're set as F keys to see if it makes any difference.

  10. 8 Posted by Bryan on 18 Dec, 2012 09:52 PM

    Bryan's Avatar

    Deleting those keys solves that issue though now creates a new one. I've found an article that seems to be the source of this problem where an external apple keyboard the UP key is sending UP & F6 at the same time. So, this definitely is seeming like it's nothing to do with your guys app +1 but rather just the apple external keyboards.

    https://discussions.apple.com/thread/3568535?start=0&tstart=0

    If I find a final solution to this I will post here in case anyone else runs into the problem. Besides that I'd consider this issue closed with you guys. Thanks for bearing with me looking into it.

  11. 9 Posted by Bryan on 18 Dec, 2012 10:28 PM

    Bryan's Avatar

    Somehow deleting the Move to pane hotkey fixed that issue, then the F6 key was mapped to open in terminal window. By removing both of those that solves my immediate issue of being able to use Path Finder.

    The core issue still seems to just be with the Apple Keyboard and the Up key also sending F6 command. I haven't found any specific solution and it's not doing it right now. I can't consistently duplicate the problem.

    You can feel free to close this thread. If the problem starts happening again in the next couple days and I find a solution I'll post otherwise I'm taking the solution as getting a new keyboard.

    One place mentioned that the issue with the Up key on the external keyboard was from having NumLock turned on which I've tried to activate / deactivate to duplicate the issue but I can't.

    Activate / Deactivate NumLock on Mac assuming you have the external keyboard wide version with the number pad do this.
    Either Shift + Clear or Alt + Shift + Clear

  12. 10 Posted by Damazio on 19 Dec, 2012 12:47 AM

    Damazio's Avatar

    Thanks for the report Bryan and glad you found the problem which is indeed strange.
    Short of having to pay for a new keyboard, you can try KeyRemap4MacBook but I'm not sure if it will help remapping/resetting the key.

    To re-open this thread you just need to reply back, in case you find a solution to your problem.

    Cheers.

  13. Damazio closed this discussion on 19 Dec, 2012 12:47 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac