Select next pane in dual browser mode!

John's Avatar

John

09 Dec, 2012 08:25 PM

Hi, I had a keyboard shortcut mapped to 'select next pane' to easily swap between R/L panes. Did this feature get removed in the most recent update? If so, what is the workaround?

Thanks.

  1. Support Staff 1 Posted by Dragan on 11 Dec, 2012 12:14 AM

    Dragan's Avatar

    John, due to many, many requests, we removed the Select Next Pane menu command and replace it with TAB and SHIFT+TAB key shortcuts. So, when you're in the Dual Pane mode, use TAB to select the other pane. When in the Single Pane mode, TAB and SHIFT+TAB return to their default behaviour.

  2. Dragan closed this discussion on 11 Dec, 2012 12:14 AM.

  3. John re-opened this discussion on 11 Dec, 2012 05:24 AM

  4. 2 Posted by John on 11 Dec, 2012 05:24 AM

    John's Avatar

    Apologies for reopening this ticket just to comment, but let me just say how brilliant this is. I had a keyboard shortcut remapped from swap window (internally to an application), splat+`. To me this was somewhat natural, since my second pane really substituted ever having a need for multiple windows.

    Unfortunately, this meant that I did have to find a workaround for multiple WINDOWS (versus multiple panes). I typically used multiple windows as a clean session, if you will.

    Anyway, the point is, tab is extremely easy, and doesn't override anything I was naturally using in PF, since everything else I need has a keyboard shortcut. And now I have window switching AND pane switching. Cheers.

    PS I mapped splat+c as copy unix path, as opposed to copy (file?) using System Preferences keyboard shortcuts, but I'd love to see this as a proper option within PF. I might be alone.

  5. 3 Posted by soob on 11 Dec, 2012 05:37 AM

    soob's Avatar

    Unfortunately auto-complete is now broken in a Terminal session in the Preview drawer when using Dual Pane mode. Used to be able to type a few characters, press Tab so the shell can auto-complete. Now must be in a separate Terminal window.

  6. 4 Posted by John on 11 Dec, 2012 05:42 AM

    John's Avatar

    Haha, indeed tab completion is broken in the terminal. I rarely use the PF terminal, mostly because I've never figured out how to get the terminal background color to be black (it may be clear I've never actually looked). My entire .bashrc etc. color schemes are based on dark bg terms, and I live inside iTerm 2 and Terminal.app all day anyhow, so my workaround has been copy unix path as an easy way to access files from PF. Granted, I love the option of terminal drawers in PF, so I expect this issue to be resolved too! In my experience you guys do a great job at this, so I'm happy to be patient about it. Regards

  7. 5 Posted by Peter B on 11 Dec, 2012 12:12 PM

    Peter B's Avatar

    I would like this feature to be fixed too, I use PF terminal often and while using TAB in dual pane mode is perfect feature, I also use autocompletion in terminal. So when focus is in terminal, TAB should work like before.

  8. 6 Posted by Damazio on 11 Dec, 2012 02:46 PM

    Damazio's Avatar

    The TAB issue in the terminal will be fixed in the next 6.1.3beta (press Option while checking for updates).

  9. Damazio closed this discussion on 11 Dec, 2012 02:46 PM.

  10. Dragan re-opened this discussion on 11 Dec, 2012 03:20 PM

  11. Support Staff 7 Posted by Dragan on 11 Dec, 2012 03:20 PM

    Dragan's Avatar

    Guys, I can only apologise for the inconvenience, I completely overlooked usage of tab/shift+tab in other panes/drawers.

    This is already fixed in the newest beta of version 6.1.3. if you're willing to test (and use) this, you can already get the latest beta. Just hold down alt/option key while checking for updates from the main menu (Path Finder > Check for Updates) and you should get the latest beta build (1517) of version 6.1.3.

  12. Dragan closed this discussion on 11 Dec, 2012 03:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac