Do you have any Tips & Tricks to increase my productivity?

In this section, we'll try our best to cover some of our favorite tricks, hotkey combinations and ways to customize Path Finder, to better serve multiple workflows and environments.

Quickly Copy, Move and Alias

Dragging and dropping while holding a modifier key can perform a different operation, as follows:


  • Within the same volume - ⌥ + Drag and drop
  • Between different volumes - Drag and drop


  • Within the same volume - Drag and drop
  • Between different volumes - ⌘ + Drag and drop


  • Within/between any volume - ⌥ + ⌘ + Drag and drop

Get Info on multiple items

If you have multiple items selected, instead of opening multiple Get Info windows, you can use a single floating window called Inspector. This special window has also the benefit of updating in real-time so, if you select extra items with ⌘ + Click, the Size section will update, accordingly. This is also useful to set attribute flags on multiple items in one go.

To call the Inspector window, just press ⌥ + ⌘ + I.

Tidy up the Contextual Menu

If you like to keep your Contextual Menu simple and organized, you can add just the commonly used functions in Preferences > Features > Contextual Menu, by dragging items from the Commands pane to the Contextual Menu pane.

The functions you rarely use, you can add them to the Action Menu (click on the Contextual Menu drop-down menu) which will show up on the Action Toolbar button (gear icon).

Don't forget to add some dividers (first item on the Commands pane) to keep it neat and tidy.

Extra Window functions

Path Finder has some additional Window manipulation features not available in the regular Finder, all available in the Window menu:

  • Clone - Duplicates the current browser window
  • Float - Sets the focused window/module always on top
  • Hides on Deactivate - Sets the focused window/module to hide when switching from Path Finder to another application

Use the old File Transfer window

Despite Path Finder 6 introduces a new cool Progress Toolbar pop-up button, if you wish to have the old window automatically pop-up on a file transfer, just remove the Progress Toolbar button.

Remember, you can have it both ways and invoke the window manually on Window > File Operations or just press ⌥ + ⌘ + L. You can also set this window to Float on Window > Float so it never gets lost in the background.

Bring back some color to the Sidebar

If you prefer the old colored icons on your Sidebar, available before the release of OS X 10.7, now you can have them back. Actually, Path Finder goes ahead and offers you both worlds.

Just click on the gear button at the bottom of the current Sidebar and create a New Sidebar. Remember every new Sidebar will be available only to Path Finder while the original Standard Sidebar will be in sync with Finder's.

View invisible files and packages as folders

Power users may swear on using the Terminal for certain tasks but, let's face it, we shouldn't have to use it to simply browse what the system is hiding from our eyes.

Toggling the visibility of hidden files is as easy as clicking on View > Show Invisible Files or going to View > Customize Toolbar and adding the Show Invisibles Toolbar button. For a quicker access, just assign your favorite hotkey in Preferences > Features > Keyboard > View > Show Invisible Files.

The same can be done when you need to browse packages as folders (an application or iPhoto library, for example).

Try to get in your Applications folder, switch to List View and toggle this behavior in View > Show Package Contents. You'll see that expanding arrows will appear and realize that applications are only folders. Only advanced users will need to tamper with application's contents since any careless modification can render an application useless but for libraries, for example, you'll see that they can be hiding real content, like your iTunes audio files or iPhoto image files.

You can also browse package contents without the need to switch on the option above, by adding the Show Package Contents or Contents command to your Contextual Menu. The first command will get you inside the selected package the same way when you double click on a folder while the second command will present the package contents hierarchically.

Set different view options for individual folders

Note: If you're using Path Finder 6.2+, please refer to this guide.

Have you ever wanted to use a specific sorting in the Applications folder and a completely different one in the Downloads folder? Of course you have.

Get in your target folder and go to View > Show View Options (⌘ + J, as default). This is where you set folder preferences. Now, notice that on the top-left of the View Options window there's a small button to switch between All windows and This window only (think of All folders and This folder only for the sake of simplicity).

Now, you only have to switch to This window only when you're in your subject folder and make the desired changes. Also note that each View (Icons, List, Columns) use their own settings, independently from one another, so you can have bold folders in Icon View but not in List View, for example.

The All windows settings are sticky so they persist across restarts and tab re-opening, contrary to sorting directly on the browser window, by clicking on the column headers in List View or using View > Sort by, which is temporary and only apply while the current folder is being viewed.

The This window only settings are automatically changed if you sort directly on the browser window, by clicking on the column headers in List View or using View > Sort by, so you can change the sort of a folder with specific settings, permanently, without going into the View Options a second time.

Don't forget about the Smart sorting option in the View Options. That option, if enabled, uses the settings in Preferences > Browser > Smart Sort order, where you can change the actual order of which items you want to see first, in the browser, or even disable items you don't want to be affected by the Smart Sorting. This option, when switched in View > Smart Sorting On, is also sticky to both All windows and This window only, so you can enable or disable it permanently, on the spot, without going into the View Options.

Filter files by type

Do you need to filter out jpeg files inside a folder (maybe with more subfolders) with all kind of mixed file types? It's very easy and there's a couple of ways you can do it.

  • Select or be inside your desired folder, choose Search > Selection on the Toolbar's Search Bar drop-down menu, type jpg and press Enter.

    All files with a jpg extension will be presented in the browser, in flat view (no hierarchy).

    If you wish to simply filter a specific file type in the current folder without searching in subfolders, just choose Filter > by Extension on the Search Bar.

  • First, make sure you are in List View and have the Select button on your Toolbar ( View > Customize Toolbar ).

    Select your base folder and hold while you click on the expanding triangle (it will expand all subfolders).

    Then, click on the Select button, switch to the Extension tab, type jpg and enable Ignore case. Finally, hit Select to preview while keeping the selection sheet open or Select & Close when you're finished.

    All files with a jpg extension will be selected in the browser, within the displayed hierarchy.

    If you enable Extend selection and type in a new extension (eg. png, for example) it will add to the current selection so both jpg and png files will be selected.

    Also, take some time to take a look at the Select tool's tabs and find new ways to filter items based on a wide variety of criteria options.

Uninstall applications

Note: As a note of caution, we should tell you beforehand that you should only use this tip if you're familiar with OS X's paths, frameworks, applications and other dependencies since trashing the wrong items can render your system useless.

Almost all applications leave left-overs when we trash them, even if just the preferences file. There are specific third-party applications designed for uninstalling purposes but most of them won't find everything, on some applications, for a simple reason: the left-over files may be named after the company name or something else different from the application name itself. Most users won't mind a couple of left-overs since these files are often small in size but if you like to keep your system as clean as possible, you can try the following procedure.

Open Window > Find Window or hit ⌘ + F. On the top-left of the Toolbar you'll notice the Spotlight/Search icon. Always use the Search function (represented by a magnifying glass over a folder) if you really want to find everything, including invisible files (Spotlight only searches for files specifically indexed by OS X).

Next, make sure your boot volume is selected on the Location Bar, enter the name of the application you want to uninstall in the Name field, with a Partial match, and press Enter to start the search. If the application in question was recently installed, we strongly suggest to sort the results by Date Modified, since files created by the application will have a similar date, and to disable View > Smart Sorting (this setting will only apply to the Find window, not to your working window).

At this stage, it's important to let the search finish before starting to select items for deletion, since selections stick to the row and not to the file itself, which will make new results "occupy" the selection space.

As stated in the first paragraph, some knowledge is required to idenify the common paths used to store application's files ( Preferences, Caches and Application Support being the main ones ) but even an experienced user is advised to check the Path column (be careful with results from /usr, /bin, etc.).

After you select the right items, just trash them. You can repeat the procedure taking into account the following patterns (capitalization is not necessary):

  • Application name (eg. audio recorder and audiorecorder, if the application name has more than one word)
  • Company name (eg. cool software and coolsoftware, if the company name has more than one word)

If you still want to uninstall most application left-overs but don't feel so confident, you can try a third-party application or the Spotlight function (represented by a blue circled magnifying glass) in the Find window's Toolbar. It will still find the common files associated with the application in question but not invisible files or files outside indexed zones.

Remove items from the Sidebar

Removing items from the Sidebar doesn't follow the same pattern for every section so here's how you do it:


  • Click on the gear button at the bottom of the Sidebar and choose Hide Device.

PLACES (the same as Finder's FAVORITES in OS X Lion)

  • Just drag them out of the Sidebar.


  • Remove them manually from /Users/<username>/Library/Favorites.


  • Just drag them out of the Sidebar.


  • This section is no longer used in OS X Lion's Finder and it's not editable in Path Finder.

Starting from OS X Lion, Spotlight searches, saved (in the default location /Users/<username>/Library/Saved Searches) and Added to the Sidebar, in Finder, will show up in Path Finder's PLACES section (Finder's FAVORITES) so there's not a dedicated Smart Folder section anymore. You can also add OS X's default Canned Searches to Path Finder's PLACES section, just by dragging them in from /System/Library/CoreServices/

Path Finder 6 can save its own searches in Window > Find Window, using Spotlight mode, by clicking on the Saved Searches Toolbar button. These saved searches can only be accessed from the same Toolbar button drop-down menu.

You can also hide specific sections by clicking on the gear button at the bottom of the Sidebar and choosing Hide Section. Finally, don't forget that only the Standard Sidebar is in sync with Finder's Sidebar so, any items added in Finder (including All My Files in Finder's Preferences > Sidebar) will reflect in Path Finder.