Not authorized to send Apple events to Terminal

stefan_pachner's Avatar

stefan_pachner

08 Dec, 2018 04:37 PM

Hi,

I would like to make PF to call Terminal or iTerm2 with current directory selected. This does work fine on 10.13.6 but not on Mac OS 10.14. PF is in quarantine. I checked this by xattr /Applications/"Path Finder.app"

Console shows this when tried.

Refusing TCCAccessRequestIndirect for service kTCCServiceAppleEvents and client /Applications/Path Finder.app[0] without NSAppleEventsUsageDescription key

Open Terminal by clicking on “Terminal” in
{ NSAppleScriptErrorAppName = Terminal; NSAppleScriptErrorBriefMessage = "Not authorized to send Apple events to Terminal."; NSAppleScriptErrorMessage = "Not authorized to send Apple events to Terminal."; NSAppleScriptErrorNumber = "-1743"; NSAppleScriptErrorRange = "NSRange: {701, 33}"; }

regards

Stefan

  1. Support Staff 1 Posted by Path Finder Sup... on 09 Dec, 2018 10:37 AM

    Path Finder Support Team's Avatar

    Hi Stefan, 

    Please confirm, am I right to assume that you've tried adjusting the default terminal app in the PF Preferences? 

    Best Regards,
    Jordan 
    Path Finder Support Team

  2. Path Finder Support Team closed this discussion on 09 Dec, 2018 10:37 AM.

  3. stefan_pachner re-opened this discussion on 09 Dec, 2018 11:28 AM

  4. 2 Posted by stefan_pachner on 09 Dec, 2018 11:28 AM

    stefan_pachner's Avatar

    Hi,

    I appreciate the quick response to custom problems.

    Yes, I was using the PF Preferences and added iTerm or Terminal, neither worked at is does on my other machine. The Apps are called, the focus changed or even the App is started when it was not running before. But the directory is not changed to that PF was currently in. So the shortcut cannot be used as is supposed to.

    And a correction to my initial thread. I wanted to say that PF is NOT in quarantine. I checked this by xattr /Applications/"Path Finder.app“. No output by this command, which is fine.

    regards

    Stefan

    > Am 09.12.2018 um 11:37 schrieb Path Finder Support Team <[email blocked]>:
    >
    > From: Path Finder Support Team (Cocoatech Support)
    > Subject: Not authorized to send Apple events to Terminal
    >
    > Hi Stefan,
    >
    > Please confirm, am I right to assume that you've tried adjusting the default terminal app in the PF Preferences?
    >
    > Best Regards,
    > Jordan
    > Path Finder Support Team
    >
    >
    >
    >
    >
    > View this discussion at our support site online: http://support.cocoatech.com/discussions/problems/124744-not-authorized-to-send-apple-events-to-terminal
    >
    > ---
    >
    > To unsubscribe and stop receiving emails from http://support.cocoatech.com, visit http://support.cocoatech.com/unsubscribe/770eb0117608f579940da3e93ece444c27734db4

  5. Support Staff 3 Posted by Path Finder Sup... on 09 Dec, 2018 01:59 PM

    Path Finder Support Team's Avatar

    Hi Stefan, 

    We've submitted this issue to our developers, too. 
    Just wanted to confirm if I get everything right. 
    Thank you for the additional details and your contribution! 

    Please feel free to write us back and we will be happy to assist you.

    Best Regards,
    Jordan 
    Path Finder Support Team

  6. Path Finder Support Team closed this discussion on 09 Dec, 2018 01:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac