Pease include Path Finder 8 system requirements on the home page.

leocpedersen's Avatar

leocpedersen

05 Dec, 2018 04:19 AM

Please stop forcing your customers through a difficult search just to see if their systems are compatible with your new release.

It is very frustrating to only find an outdated knowledge base page with version 7 system requirements.

We expect to see system requirements for any new software on the home page.

Thanks.
A long-time customer trying to upgrade.

  1. Support Staff 1 Posted by Path Finder Sup... on 05 Dec, 2018 01:37 PM

    Path Finder Support Team's Avatar

    Hi,

    Sorry for the inconvenience. 

    Your suggestion makes perfect sense and we've already passed it down to our developers. 
    Just in case, PF8 is compatible with El Capitan and newer macOS. 

    Please feel free to write us back and we will be happy to assist you.

    Best Regards,
    Jordan 
    Path Finder Support Team

  2. Path Finder Support Team closed this discussion on 05 Dec, 2018 01:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac