How to prevent opening Webinformation PathFinder JSContext

bernd's Avatar

bernd

18 Jun, 2018 02:51 PM

Hi,
launching PathFinder 8 (evaluation version) will always open a JSContext window (javascript console?). How to avoid this?
Regards
Bernd

  1. Support Staff 1 Posted by Path Finder Sup... on 18 Jun, 2018 03:08 PM

    Path Finder Support Team's Avatar

    Hi Bernd,

    That's unusual. Does it happen only with PathFinder? 
    Does your PathFinder have ".dmg" extension? Have you downloaded it from our site? 

    Looking forward to your reply. 

    Best Regards,
    Jordan 
    Path Finder Support Team

  2. Path Finder Support Team closed this discussion on 18 Jun, 2018 03:08 PM.

  3. bernd re-opened this discussion on 18 Jun, 2018 03:28 PM

  4. 2 Posted by bernd on 18 Jun, 2018 03:28 PM

    bernd's Avatar

    Hi Jordan,
    after some testing I need to specify the procedure: I can reproduce the behavior by (re)starting PathFinder and double clicking a hidden file for editing (e.g. .bashrc). This file will be openend by Path Finders built in text editor (default setting) and in addition to this the JSContext window opens below Path Finder window. See second screen shot... Any Idea? Double clicking the same file in Finder works well.
    Regards
    Bernd

  5. Support Staff 3 Posted by Path Finder Sup... on 18 Jun, 2018 03:34 PM

    Path Finder Support Team's Avatar

    Hi Bernd,

    Will perhaps help to adjust preferences via PathFinder > Preferences > General? 
    For example, uncheck "Open with PathFinder > TextEdit documents". Or change the default Text Editor here. 

    Let me know if this helps. 

    Best Regards,
    Jordan 
    Path Finder Support Team

  6. Path Finder Support Team closed this discussion on 18 Jun, 2018 03:34 PM.

  7. bernd re-opened this discussion on 18 Jun, 2018 03:49 PM

  8. 4 Posted by bernd on 18 Jun, 2018 03:49 PM

    bernd's Avatar

    Hi Jordan,
    the default text editor in my PathFinder general preferences is MacVim (since PF V7). When I individually assign the file (e.g. .bashrc or .my.cnf) to be opened by MacVim, yes, it will be opened by MacVim, but the JSContext window will be opened to, as before. However, it's not a critical issue for me, I just wanted you to be informed...
    Best regards and thank you for your prompt reply
    Bernd

  9. Support Staff 5 Posted by Path Finder Sup... on 18 Jun, 2018 03:58 PM

    Path Finder Support Team's Avatar

    Hi Bernd,

    Thank you for reporting this. 

    Forwarding the additional details to our developers for the further investigation now. 

    Don't hesitate to contact us should any questions arise. 

    Best Regards,
    Jordan 
    Path Finder Support Team

  10. Path Finder Support Team closed this discussion on 18 Jun, 2018 03:58 PM.

  11. bernd re-opened this discussion on 19 Jun, 2018 02:42 AM

  12. 6 Posted by bernd on 19 Jun, 2018 02:42 AM

    bernd's Avatar

    Once again more specific: The issue does not depend on "hidden" state of files, I wrote before. The JSContext pops up always after starting PathFinder 8 and first time double clicking any editable file (e.g. plain text file).

  13. Support Staff 7 Posted by Path Finder Sup... on 20 Jun, 2018 02:33 PM

    Path Finder Support Team's Avatar

    Hi Bernd, 

    Thank you for the additional details. 

    Best Regards,
    Jordan 
    Path Finder Support Team

  14. Path Finder Support Team closed this discussion on 20 Jun, 2018 02:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac